首页 > 其他 > 详细

TOJ-1320 Billiard

时间:2017-01-30 15:32:38      阅读:272      评论:0      收藏:0      [点我收藏+]
In a billiard table with horizontal side a inches and vertical side b inches, a ball is launched from the middle of the table. After s > 0 seconds the ball returns to the point from which it was launched, after having made m bounces off the vertical sides and n bounces off the horizontal sides of the table. Find the launching angle A (measured from the horizontal), which will be between 0 and 90 degrees inclusive, and the initial velocity of the ball.

Assume that the collisions with a side are elastic (no energy loss), and thus the velocity component of the ball parallel to each side remains unchanged. Also, assume the ball has a radius of zero. Remember that, unlike pool tables, billiard tables have no pockets.

Input

Input consists of a sequence of lines, each containing five nonnegative integers separated by whitespace. The five numbers are: a, b, s, m, and n, respectively. All numbers are positive integers not greater than 10000.

Input is terminated by a line containing five zeroes.

Output

For each input line except the last, output a line containing two real numbers (accurate to two decimal places) separated by a single space. The first number is the measure of the angle A in degrees and the second is the velocity of the ball measured in inches per second, according to the description above.

Sample Input

100 100 1 1 1
200 100 5 3 4
201 132 48 1900 156
0 0 0 0 0

Sample Output

45.00 141.42
33.69 144.22
3.09 7967.81



Source: Waterloo Local Contest Jun. 19, 1999

 

根据动量守恒,球无论碰撞多少次,其与水平方向的夹角(只算锐角)不变,则可知球总共在水平方向移动距离a*m英寸,垂直方向移动距离b*n英寸。

#include<stdio.h>
#include <cmath>

#define PI acos(-1) 
int main(){
    double a,b,s,m,n,agl,v;
    while(~scanf("%lf%lf%lf%lf%lf",&a,&b,&s,&m,&n)&&a&&b&&s&&m&&n)
    {
        agl = atan((b*n)/(a*m))*180/PI;
        v = sqrt(b*n*b*n+a*m*a*m)/s;
        printf("%.2lf %.2lf\n",agl,v);
    }
    return 0;
}

 

TOJ-1320 Billiard

原文:http://www.cnblogs.com/shenchuguimo/p/6358100.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!