首页 > 其他 > 详细

队列练习2

时间:2017-02-06 21:57:31      阅读:226      评论:0      收藏:0      [点我收藏+]

题目描述 Description

(此题与队列练习1相比改了2处:1加强了数据 2不保证队空时不会出队)
给定一个队列(初始为空),只有两种操作入队和出队,现给出这些操作请
输出最终的队头元素。 操作解释:1表示入队,2表示出队

输入描述 Input Description

N(操作个数)
N个操作(如果是入队则后面还会有一个入队元素)
具体见样例(输入保证队空时不会出队)

输出描述 Output Description

最终队头元素,若最终队空,或队空时有出队操作,输出”impossible!”(不含引号)

样例输入 Sample Input

3
1 2
2
2

样例输出 Sample Output

impossible!

数据范围及提示 Data Size & Hint

对于100%的数据  N≤100000 元素均为正整数且小于等于10^8

#include<iostream>

#include<cstdio>

#include<algorithm>

#include<cstring>

 

using namespace std;

 

int N,m,tail,head;

int a[100000+15];

 

int main()

{

cin>>N;

for(int i=1;i<=N;i++)

{

cin>>m;

if(m==1)

{

cin>>a[++tail];

}

if(m==2)

{

head++;

if(head-1==tail)

{

cout<<"impossible!";

return 0;

}

}

}

if(tail-head==0)

cout<<"impossible!";

else

cout<<a[head+1];

return 0;

}

队列练习2

原文:http://www.cnblogs.com/Shy-key/p/6371734.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!