首页 > 其他 > 详细

ACdream1077:LCM Challenge

时间:2014-05-25 16:32:16      阅读:450      评论:0      收藏:0      [点我收藏+]

Problem Description

Some days ago, I learned the concept of LCM (least common multiple). I‘ve played with it for several times and I want to make a big number with it.

But I also don‘t want to use many numbers, so I‘ll choose three positive integers (they don‘t have to be distinct) which are not greater thann. Can you help me to find the maximum possible least common multiple of these three integers?

Input

The first line contains an integer n (1?≤?n?≤?10^6) — the n mentioned in the statement.

Output

Print a single integer — the maximum possible LCM of three not necessarily distinct positive integers that are not greater than n.

Sample Input

9

Sample Output

504

题意:在n内找三个数,这三个数的最小公倍数,是n里面任意三个数的最小公倍数最大的
思路:这道题以前做过,但不记得在哪里了,思路就是找三个互质的数
奇数的话,那么n,n-1,n-2必定互质,那么n*(n-1)*(n-3)便是最大的
偶数的话,n-1是奇数,适用上面的式子,这是(n-1)*(n-2)*(n-3)
要么就是n,n-1,n-3互质,这就是n*(n-1)*(n-3),只要比较两者谁更大就可以了

#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define ll long long

int main()
{
    ll n,ans,i;
    while(~scanf("%lld",&n))
    {
        if(n == 1)
        {
            printf("1\n");
            continue;
        }
        else if(n == 2)
        {
            printf("2\n");
            continue;
        }
        else if(n == 3)
        {
            printf("6\n");
            continue;
        }
        if(n%2)
            ans = n*(n-1)*(n-2);
        else
        {
            ans = (n-1)*(n-2)*(n-3);
            ans = max(ans,n*(n-1)*(n-3));
        }
        printf("%lld\n",ans);
    }

    return 0;
}


ACdream1077:LCM Challenge,布布扣,bubuko.com

ACdream1077:LCM Challenge

原文:http://blog.csdn.net/libin56842/article/details/26822371

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!