首页 > 其他 > 详细

codevs 2549 自然数和分解

时间:2017-02-27 23:29:21      阅读:411      评论:0      收藏:0      [点我收藏+]
时间限制: 1 s
 空间限制: 32000 KB
 题目等级 : 白银 Silver
题目描述 Description

把自然数N分解为若干个自然数之和,输出方案数。

输入描述 Input Description

N,(1≤n≤50)

输出描述 Output Description

方案数

样例输入 Sample Input

5

样例输出 Sample Output

7

数据范围及提示 Data Size & Hint

5 可分为

1 1 1 1 1
1 1 1 2
1 1 3
1 2 2
1 4
2 3

bfs 
#include <cstdio>

int N,ans,i;
void dfs(int sum,int pos)
{
    if(sum==0)
    {
        ans++;
        return;
    }
    for(int i=pos;i<=sum;i++)
    dfs(sum-i,i);
}
int main()
{
    scanf("%d",&N);
    dfs(N,1);
    printf("%d",ans);
    return 0;
}

 

 

codevs 2549 自然数和分解

原文:http://www.cnblogs.com/ruojisun/p/6476581.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!