首页 > 其他 > 详细

HDU1003 Max Sum

时间:2014-02-01 14:15:50      阅读:448      评论:0      收藏:0      [点我收藏+]

问题描述:找出最长连续子序列和

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
Case 1: 14 1 4 Case 2: 7 1 6

#include <iostream>
using namespace std;

int main()
{
	freopen("C:\\in.txt","r",stdin);
	int T;
	int k=0;
	scanf("%d",&T);
	while(T--){
		int N;
		scanf("%d",&N);
		int max=-0x7fffffff,start,end,temp=1,sum=0;
		int num;
		for(int i=0;i<N;i++){
			scanf("%d",&num);
			sum+=num;
			if(sum>max){
				max=sum;
				start=temp;
				end=i+1;
			}
			if(sum<0){
				sum=0;
				temp=i+2;
			}
		}
		printf("Case %d:\n%d %d %d\n",++k,max,start,end);
		if(T!=0)printf("\n");
	}
	return 0;
}


HDU1003 Max Sum

原文:http://blog.csdn.net/starcuan/article/details/18893381

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!