首页 > 其他 > 详细

POJ 3579- Median

时间:2014-06-01 14:08:22      阅读:461      评论:0      收藏:0      [点我收藏+]


Description

Given N numbers, X1, X2, ... , XN, let us calculate the difference of every pair of numbers: ∣Xi - Xj∣ (1 ≤ i j N). We can get C(N,2) differences through this work, and now your task is to find the median of the differences as quickly as you can!

Note in this problem, the median is defined as the (m/2)-th  smallest number if m,the amount of the differences, is even. For example, you have to find the third smallest one in the case of m = 6.

Input

The input consists of several test cases.
In each test case, N will be given in the first line. Then N numbers are given, representing X1, X2, ... , XN, ( Xi ≤ 1,000,000,000  3 ≤ N ≤ 1,00,000 )

Output

For each test case, output the median in a separate line.

Sample Input

4
1 3 2 4
3
1 10 2

Sample Output

1
8

Source



题目大意:给N个数,两两相减有m=C(N,2)种结果,找出(m/2)-th小的差。
思路:两次二分,第一次二分找那个差数,第二次算出左边有多少比他小的数可以使它们的差小于第一次二分时的数
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.OutputStreamWriter;
import java.io.PrintWriter;
import java.io.StreamTokenizer;
import java.util.*;

public class Main {
	static int n;
	static int a[] = new int[100000];
	static int m;
	static int solve(int x,int y,int val,int flag){
		while(x<=y){
			int mid=(x+y)/2;
			if(val-a[mid]<=flag)
				y=mid-1;
			else
				x=mid+1;
			
		}
		return y;
	}
	static boolean ok(int val){
		int j,k=0;
		for(int i=2;i<=n;i++){
			j=solve(1,i-1,a[i],val);
			k+=i-j-1;
		}
		if(k<m)
			return false;
		else 
			return true;
	}
	public static void main(String[] args) throws IOException {
		//Scanner scan = new Scanner(System.in);
		StreamTokenizer st = new StreamTokenizer(new BufferedReader(
				new InputStreamReader(System.in)));
		PrintWriter out = new PrintWriter(new OutputStreamWriter(System.out));
		while (st.nextToken()!=StreamTokenizer.TT_EOF) {
			n =(int)st.nval;
			if(n*(n-1)/2%2!=0){
				m=(n*(n-1)/2+1)/2;
			}
			else
				m=n*(n-1)/2/2;
			
			for (int i = 1; i <=n; i++) {
				st.nextToken();
				a[i] = (int)st.nval;
			}
			Arrays.sort(a,1,n+1);
			int l = 0, r = a[n]-a[1];
			while(l<=r){
				int mid=(l+r)/2;
				if(ok(mid))
					r=mid-1;
				else
					l=mid+1;
			}
			out.println(l);
			out.flush();
		}
	}

}

POJ 3579- Median,布布扣,bubuko.com

POJ 3579- Median

原文:http://blog.csdn.net/kimi_r_17/article/details/27855345

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!