首页 > 移动平台 > 详细

POJ3321:Apple Tree(树状数组)

时间:2017-05-26 11:43:28      阅读:318      评论:0      收藏:0      [点我收藏+]

Description

There is an apple tree outside of kaka‘s house. Every autumn, a lot of apples will grow in the tree. Kaka likes apple very much, so he has been carefully nurturing the big apple tree.

The tree has N forks which are connected by branches. Kaka numbers the forks by 1 to N and the root is always numbered by 1. Apples will grow on the forks and two apple won‘t grow on the same fork. kaka wants to know how many apples are there in a sub-tree, for his study of the produce ability of the apple tree.

The trouble is that a new apple may grow on an empty fork some time and kaka may pick an apple from the tree for his dessert. Can you help kaka?

技术分享

Input

The first line contains an integer N (N ≤ 100,000) , which is the number of the forks in the tree.
The following N - 1 lines each contain two integers u and v, which means fork u and fork v are connected by a branch.
The next line contains an integer M (M ≤ 100,000).
The following M lines each contain a message which is either
"x" which means the existence of the apple on fork x has been changed. i.e. if there is an apple on the fork, then Kaka pick it; otherwise a new apple has grown on the empty fork.
or
"x" which means an inquiry for the number of apples in the sub-tree above the fork x, including the apple (if exists) on the fork x
Note the tree is full of apples at the beginning

Output

For every inquiry, output the correspond answer per line.

Sample Input

3
1 2
1 3
3
Q 1
C 2
Q 1

Sample Output

3
2

Source

POJ Monthly--2007.08.05, Huang, Jinsong


题意:
给出一个苹果树,每一个节点一開始都有苹果
C X,假设X点有苹果,则拿掉,假设没有,则新长出一个
Q X。查询X点与它的全部后代分支一共同拥有几个苹果

思路:
思路非常巧妙,我们通过自己来编号全部苹果,每一个节点保存两个值。左值为本身,右值为其包括的全部后代中最大的编号
我们能够通过搜索来进行编号,在编好号之后,我们能够知道,对于某一点而言,我们是先通过这个点搜全然部他的后代编号才结束的。所以这个点的右值,包括了当前点全部的后代与祖先,后代必定是全部编号大于本节点的点,那么祖先呢。那必定是编号小于这个节点的点了
所以我们通过sum(rig[x])-sum(lef[x]-1)就能得到查询的答案
至于更新,仅仅须要更新当前点就可以,这样就转化为树状数组了
一開始我vector使用的vector<int> a[N]。可是一直超时,開始我还没有发现是这个的问题
后来參考别人的发现没什么不同,唯一区别的地方就在这里,于是尝试着改动成vector<vector<int> > a(N),结果就A了,坑啊

#include <iostream>
#include <stdio.h>
#include <string.h>
#include <string>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <list>
#include <algorithm>
#include <climits>
using namespace std;

#define lson 2*i
#define rson 2*i+1
#define LS l,mid,lson
#define RS mid+1,r,rson
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 100005
#define INF 0x3f3f3f3f
#define EXP 1e-8
#define lowbit(x) (x&-x)
const int mod = 1e9+7;

vector<vector<int> > a(N);
//vector<int> a[N];
int n,m,lef[N],rig[N],c[N],tot,s[N];


int sum(int x)
{
    int ret = 0;
    while(x>0)
    {
        ret+=c[x];
        x-=lowbit(x);
    }
    return ret;
}

void add(int x,int d)
{
    while(x<=n)
    {
        c[x]+=d;
        x+=lowbit(x);
    }
}


void dfs(int x)
{
    lef[x] = tot;
    for(int i = 0; i<a[x].size(); i++)
    {
        tot++;
        dfs(a[x][i]);
    }
    rig[x] = tot;
}
int main()
{
    int i,j,k,x,y;
    char op[5];
    while(~scanf("%d",&n))
    {
        MEM(lef,0);
        MEM(rig,0);
        MEM(s,0);
        MEM(c,0);
        for(i=0; i<N; i++)
            a[i].clear();
        for(i = 1; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            a[x].push_back(y);
        }
        tot = 1;
        dfs(1);
        for(i = 1; i<=n; i++)
        {
            s[i] = 1;
            add(i,1);
        }
        scanf("%d",&m);
        while(m--)
        {
            scanf("%s%d",op,&x);
            if(op[0]==‘Q‘)
            {
                printf("%d\n",sum(rig[x])-sum(lef[x]-1));
            }
            else
            {
                if(s[x])
                    add(lef[x],-1);
                else
                    add(lef[x],1);
                s[x]=!s[x];
            }
        }
    }

    return 0;
}


POJ3321:Apple Tree(树状数组)

原文:http://www.cnblogs.com/blfbuaa/p/6907561.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!