首页 > 其他 > 详细

POJ 3615 Cow Hurdles.

时间:2014-06-08 15:54:41      阅读:488      评论:0      收藏:0      [点我收藏+]

Description

Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows‘ practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1..N. A set of M (1 ≤ M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1..M. Path i travels from station Si to station Ei and contains exactly one hurdle of height Hi (1 ≤ Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task i comprises two distinct numbers, Ai and Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N), which connote that a cow has to travel from station Ai to station Bi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling from Ai to Bi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.
 

Input

* Line 1: Three space-separated integers: NM, and T
* Lines 2..M+1: Line i+1 contains three space-separated integers: Si , Ei , and Hi 
* Lines M+2..M+T+1: Line i+M+1 contains two space-separated integers that describe task i: Ai and Bi

Output

* Lines 1..T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

Sample Input

5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1

Sample Output

4
8
-1

Source

====

Floyd算法的变形,是找从A到B的所有路径中的最小的最大高度。

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
using namespace std;

const int N=305;
const int INF=0x3f3f3f3f;

int n,m,t,s,e;
int d[N][N];

void Floyd()
{
    for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                d[i][j]=min(d[i][j],max(d[i][k],d[k][j]));    //注意这里的写法。
}

int main()
{
        scanf("%d%d%d",&n,&m,&t);
        memset(d,0x3f,sizeof(d));
        int p,q,v;
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&p,&q,&v);
            d[p][q]=v;
        }
        Floyd();
        for(int i=1;i<=t;i++)
        {
            scanf("%d%d",&s,&e);
            int ans=d[s][e];
            if(ans==INF)
                printf("-1\n");
            else
                printf("%d\n",ans);
        }
    return 0;
}


POJ 3615 Cow Hurdles.,布布扣,bubuko.com

POJ 3615 Cow Hurdles.

原文:http://blog.csdn.net/darwin_/article/details/28887905

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!