首页 > 其他 > 详细

HDOJ 2196 Computer

时间:2014-02-05 23:41:06      阅读:598      评论:0      收藏:0      [点我收藏+]

经典的树形DP。。。

Time Limit: 1000MS   Memory Limit: 32768KB   64bit IO Format: %I64d & %I64u

[]   [Go Back]   [Status]  

Description

A school bought the first computer some time ago(so this computer‘s id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 
bubuko.com,布布扣


Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.
 

Input

Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.
 

Output

For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).
 

Sample Input

5 1 1 2 1 3 1 1 1
 

Sample Output

3 2 3 4 4
 

Source

[]   [Go Back]   [Status]  



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=22000;
const int INF=0x3f3f3f3f;

int Adj[maxn],Size;

struct E
{
	int to,next,len;
}Edge[maxn];

void init()
{
	Size=0;
	memset(Adj,-1,sizeof(Adj));
}

void Add_Edge(int u,int v,int w)
{
	Edge[Size].to=v;
	Edge[Size].len=w;
	Edge[Size].next=Adj[u];
	Adj[u]=Size++;
}

int n,dp[maxn][3];

void dfs1(int f,int u)
{
    int biggest=0,bigger=0;
    for(int i=Adj[u];~i;i=Edge[i].next)
    {
        int v=Edge[i].to;
        int w=Edge[i].len;
        if(v==f) continue;
        dfs1(u,v);
        int temp=dp[v][0]+w;
        if(temp>=biggest)
        {
            bigger=biggest;
            biggest=temp;
        }
        else if(temp>bigger)
        {
            bigger=temp;
        }
    }
    dp[u][0]=biggest;
    dp[u][1]=bigger;
}

void dfs2(int f,int u)
{
    for(int i=Adj[u];~i;i=Edge[i].next)
    {
        int v=Edge[i].to;
        int w=Edge[i].len;
        if(v==f) continue;
        dp[v][2]=max(dp[u][2],(dp[v][0]+w==dp[u][0])?dp[u][1]:dp[u][0]) + w ;
        dfs2(u,v);
    }
}

int main()
{
while(scanf("%d",&n)!=EOF)
{
	init();
	for(int i=2;i<=n;i++)
	{
		int a,b;
		scanf("%d%d",&a,&b);
		Add_Edge(i,a,b);
		Add_Edge(a,i,b);
	}
	memset(dp,0,sizeof(dp));
    dfs1(-1,1);
    dfs2(-1,1);
	for(int i=1;i<=n;i++)
    {
        printf("%d\n",max(dp[i][0],dp[i][2]));
    }
}
	return 0;
}


HDOJ 2196 Computer

原文:http://blog.csdn.net/u012797220/article/details/18940215

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!