首页 > 其他 > 详细

Big Number------HDOJ杭电1212(大数运算)

时间:2014-06-18 21:09:48      阅读:422      评论:0      收藏:0      [点我收藏+]
Problem Description
As we know, Big Number is always troublesome. But it‘s really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
 

Input
The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
 

Output
For each test case, you have to ouput the result of A mod B.
 

Sample Input
2 3 12 7 152455856554521 3250
 

Sample Output
2 5 1521
 
题意简单,不用讲的呐!
要是你看不懂我非常操心你的四级肿么办!!!!!!
直接上代码,能够作为模板!!!!!!
这代码有点抄袭别人的感觉;
开毛线玩笑,模板啊!!!!!!
模板不一样怎么叫模板!!!!!
#include<stdio.h>
#include<string.h>
#include<iostream>
using namespace std;

int main()
{
    int i,j,k;
    int t,n,m;
    char ch[1006];
    while(cin>>ch>>n)
    {
        m=0;
        for(i=0;i<strlen(ch);i++)
        {
            m*=10;
            m+=ch[i]-‘0‘;
            m%=n;
        }
        printf("%d\n",m);
    }
    return 0;
}

写代码能力有限,如有编程爱好者发现bug,还请指出,不胜感激!!!!!!

Big Number------HDOJ杭电1212(大数运算),布布扣,bubuko.com

Big Number------HDOJ杭电1212(大数运算)

原文:http://www.cnblogs.com/zfyouxi/p/3790335.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!