首页 > 其他 > 详细

HDU1159-Common Subsequence-LCS

时间:2017-07-19 21:12:18      阅读:310      评论:0      收藏:0      [点我收藏+]

上次写题解写到一半,写的比较具体,没写完,忘记存草稿了。。。导致现在没心情了。

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 39661    Accepted Submission(s): 18228


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

 

Sample Input
abcfbc abfcab
programming contest
abcd mnp
 

 

Sample Output
4
2
0
 
题意就是求两个字符串的最长公共子序列的长度。
LCS入门。
模板。
代码:
#include<bits/stdc++.h>
using namespace std;
const int N=1e3+10;
char s1[N],s2[N];
int dp[N][N];
int len1,len2;
void fun(){
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=len1;i++){
        for(int j=1;j<=len2;j++){
            if(s1[i-1]==s2[j-1])
                dp[i][j]=dp[i-1][j-1]+1;
            else
                dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
        }
    }
}
int main(){
   while(~scanf("%s%s",&s1,&s2)){
    len1=strlen(s1);
    len2=strlen(s2);
    fun();
    printf("%d\n",dp[len1][len2]);
   }
   return 0;
}

 

HDU1159-Common Subsequence-LCS

原文:http://www.cnblogs.com/ZERO-/p/7207653.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!