首页 > 其他 > 详细

HDU 2162(注意初始化位置!)

时间:2017-07-22 09:21:34      阅读:280      评论:0      收藏:0      [点我收藏+]

Add ‘em

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4144    Accepted Submission(s): 2976


Problem Description
Write a program to determine the summation of several sets of integers.
 

 

Input
The input file will consist of up to 250 sets of integers, where each set contains at most 100 integers and the integer values will be between –16000 and + 16000. Each set of numbers is started with the number of integers in the set, n. The next n input lines will each contain one integer of the set. You should stop processing when the size of the set, n, is<= 0.
 
Output
A single line of output should be generated for each set of integers. The line should have format shown below.
 

 

Sample Input
4 -1 3 1 1 2 19 17 5 -645 952 -1488 -5456 -9342 -1
 

 

Sample Output
Sum of #1 is 4 Sum of #2 is 36 Sum of #3 is -15979
#include <iostream>
#include<cstdio>
using namespace std;

int main()
{
    int t,a,sum,c=1;
    while(~scanf("%d",&t))
    {
        if(t<=0)
            break;
        sum=0;
        //c=1;//注意位置,不是这里初始化!
        while(t--)
        {
            scanf("%d",&a);
            sum+=a;
        }
        printf("Sum of #%d is %d\n",c++,sum);
    }
    return 0;
}

  

 

HDU 2162(注意初始化位置!)

原文:http://www.cnblogs.com/Roni-i/p/7220302.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!