首页 > 其他 > 详细

HDU2709 Sumsets

时间:2014-02-07 10:57:49      阅读:354      评论:0      收藏:0      [点我收藏+]


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

Input
A single line with a single integer, N.
 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

Sample Input
7
 

Sample Output
6
#include <iostream>
using namespace std;

__int64 a[1000001];
int main()
{
	//freopen("C:\\in.txt","r",stdin);
	__int64 n;
	int i;
    a[1]=1;a[2]=2;
    for(i=3;i<1000001;i++)
    {
        if(i%2==0)
            a[i]=a[i-2]+a[i/2];
        else
            a[i]=a[i-1];
        a[i]%=1000000000;
    }
    while(scanf("%I64d",&n)!=EOF)
        printf("%I64d\n",a[n]);
    return 0;
}


HDU2709 Sumsets

原文:http://blog.csdn.net/starcuan/article/details/18955271

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!