The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.
The goal is to take cards in such order as to minimize the total number of scored points.
For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
Input
Output
Sample Input
6 10 1 50 50 20 5
Sample Output
3650
for(int l=2;l<n;l++)
for(int i=2;i+l<=n+1;i++)
{
j=i+l-1;
dp[i][j]=1e9;
for(int k=i;k<j;k++)
{
dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+c[i-1]*c[k]*c[j]);
}
}
转移方程如图,和CSU那个石子归并类似。
1 #include<cstdio> 2 #include<cstring> 3 #include<iostream> 4 #include<algorithm> 5 6 using namespace std; 7 8 int dp[105][105],c[105]; 9 10 int main() 11 { 12 int n; 13 scanf("%d",&n); 14 for(int i=1;i<=n;i++) 15 scanf("%d",&c[i]); 16 int j; 17 for(int l=2;l<n;l++) 18 for(int i=2;i+l<=n+1;i++) 19 { 20 j=i+l-1; 21 dp[i][j]=1e9; 22 for(int k=i;k<j;k++) 23 { 24 dp[i][j]=min(dp[i][j],dp[i][k]+dp[k+1][j]+c[i-1]*c[k]*c[j]); 25 //cout<<i<<" "<<j<<" "<<dp[i][j]<<endl; 26 } 27 } 28 printf("%d\n",dp[2][n]); 29 30 31 return 0; 32 }
POJ - 1651 Multiplication Puzzle
原文:http://www.cnblogs.com/xibeiw/p/7288915.html