首页 > 其他 > 详细

hdu6092 01背包

时间:2017-08-08 22:23:01      阅读:203      评论:0      收藏:0      [点我收藏+]

Rikka with Subset

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 658    Accepted Submission(s): 297


Problem Description
As we know, Rikka is poor at math. Yuta is worrying about this situation, so he gives Rikka some math tasks to practice. There is one of them:

Yuta has n positive A1?An and their sum is m . Then for each subset S of A , Yuta calculates the sum of S .

Now, Yuta has got 2n numbers between [0,m] . For each i[0,m] , he counts the number of i s he got as Bi .

Yuta shows Rikka the array Bi and he wants Rikka to restore A1?An .

It is too difficult for Rikka. Can you help her?  
 

 

Input
The first line contains a number t(1t70) , the number of the testcases.

For each testcase, the first line contains two numbers n,m(1n50,1m104) .

The second line contains m+1 numbers B0?Bm(0Bi2n) .
 

 

Output
For each testcase, print a single line with n numbers A1?An .

It is guaranteed that there exists at least one solution. And if there are different solutions, print the lexicographic minimum one.
 

 

Sample Input
2
2 3
1 1 1 1
3 3
1 3 3 1
 

 

Sample Output
1 2
1 1 1
 
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e4+88;
typedef long long LL;
LL dp[N],B[N];
int a[N];
int main(){
    int n,m,T;
    for(scanf("%d",&T);T--;){
    memset(dp,0,sizeof(dp));
    memset(a,0,sizeof(a));
    scanf("%d%d",&n,&m);
    for(int i=0;i<=m;++i) scanf("%I64d",&B[i]);
    dp[0]=1;
    for(int i=1;i<=m;++i){
        if(dp[i]==B[i]) continue;
        a[i]=B[i]-dp[i];
        for(int j=1;j<=a[i];++j) for(int k=m;k>=i;--k) dp[k]+=dp[k-i];
    }
    int i;
    for(i=1;i<=m;++i) if(a[i]--) {printf("%d",i);break;}
    for(;i<=m;++i) while(a[i]--) printf(" %d",i);
    puts("");
    }
}

 

hdu6092 01背包

原文:http://www.cnblogs.com/mfys/p/7308968.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!