首页 > 编程语言 > 详细

解决安装ipython时Command "python setup.py egg_info" failed with error code 1 in /tmp

时间:2017-09-07 09:52:34      阅读:5978      评论:0      收藏:0      [点我收藏+]

标签:ipython   pip   failed   python2.7   ipython 6.0+   

最近使用ubuntu16.04 server版安装ipython的时候一直在报错:

IPython 6.0+ does not support Python 2.6, 2.7, 3.0, 3.1, or 3.2.     
When using Python 2.7, please install IPython 5.x LTS Long Term Support version.
python2.7 ipython Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-Vxrpi9/ipython/


下面的报错无所谓,没有解决办法,也找不到。关键是上面说明的版本信息,由于ubuntu16.04默认python版本是python2.7,所以使用原来CentOS6.x或者ubuntu14.04的习惯安装方法是不可行的,需要使用IPython 5.x LTS才可以,所以去PyPI网站下载了ipython-5.4.1-py2-none-any.whl。


具体操作步骤:

wangpeng@ubuntu:~$ wget https://pypi.python.org/packages/f7/48/5702699caf20208d61a92157c01d1eb281093e3e02e9bcd4b5031ccea6a1/ipython-5.4.1-py2-none-any.whl#md5=2b801f50b5e82a3fabca42b661568bf5
wangpeng@ubuntu:~$ sudo pip install ipython-5.4.1-py2-none-any.whl

再试一下就可以了。

wangpeng@ubuntu:~$ ipython
Python 2.7.12 (default, Nov 19 2016, 06:48:10) 
Type "copyright", "credits" or "license" for more information.
IPython 5.4.1 -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython‘s features.
%quickref -> Quick reference.
help      -> Python‘s own help system.
object?   -> Details about ‘object‘, use ‘object??‘ for extra details.
In [1]:

 



本文出自 “LINUX” 博客,请务必保留此出处http://wangpengtai.blog.51cto.com/3882831/1963283

解决安装ipython时Command "python setup.py egg_info" failed with error code 1 in /tmp

标签:ipython   pip   failed   python2.7   ipython 6.0+   

原文:http://wangpengtai.blog.51cto.com/3882831/1963283

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号