首页 > 其他 > 详细

pat 1001

时间:2017-09-23 18:31:17      阅读:246      评论:0      收藏:0      [点我收藏+]

1001. A+B Format (20)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.


Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input

-1000000 9

Sample Output

-999,991
#include <iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<stack>
using namespace std;

int main() {
	
	int m,n;
	stack<char>ans;
	char c= ‘+‘;
	scanf("%d %d",&m,&n);
	int a =m+n;
	if(a<0){
	c=‘-‘;
	a=-a;	
	}
	
	if(a==0)
	printf("%d",a);
	//ans.push(c);
	int count=0;
	
	while(a!=0){
		char digit=(char)(a%10+‘0‘);
		a=a/10;
		ans.push(digit);
		count++;
		if(count%3==0){
			ans.push(‘,‘);
		}
	}
	if(c==‘-‘)
	printf("%c",c);
	if(!ans.empty()&&ans.top()==‘,‘)
	ans.pop();
//	printf("%d",a);
 	while(!ans.empty()){
 		printf("%c",ans.top());
 		ans.pop();
	 }
	printf("\n");
	return 0;
}


pat 1001

原文:http://jerry123.blog.51cto.com/9656384/1967978

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!