首页 > 其他 > 详细

POJ3264 (RMQのST解法)

时间:2017-10-07 21:09:39      阅读:197      评论:0      收藏:0      [点我收藏+]

For the daily milking, Farmer John‘s N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. NQ+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.

Output

Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.

Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

题意,给出一串数字,有m个询问,询问l-r之间最大值和最小值的差.

好吧,这明显可以用线段树做....我知道....但可以离线实在让我忍不住了....不管了....st做法奉上....

于是,收到了素质RE四连...

技术分享

是是是,我以为网卡了,然后手贱直接交了4发,仔细一查原来j没算对,开大了....

然后改一发A掉了

技术分享

 

至于长度emmmm这只是暴力压行的结果,无视就行了.....

代码如下:

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;

int dp1[200000][20],dp2[200000][20],a[200000];

int main()
{
    int n,m;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
        dp1[i][0]=a[i];
        dp2[i][0]=a[i];
    }
    for(int j=1;j<=17;j++)
    {
        for(int i=1;i<=n;i++)
        {
            if(i+(1<<j)-1<=n)
            dp1[i][j]=max(dp1[i][j-1],dp1[i+(1<<(j-1))][j-1]);
            dp2[i][j]=min(dp2[i][j-1],dp2[i+(1<<(j-1))][j-1]);
        }
    }
    for(int i=1;i<=m;i++)
    {
        int l,r,ans=0;
        scanf("%d%d",&l,&r);
        int x=(int)(log((double)(r-l+1))/log(2.0));
        int max1=max(dp1[l][x],dp1[r-(1<<x)+1][x]);
        int min1=min(dp2[l][x],dp2[r-(1<<x)+1][x]);
        ans=max1-min1;
        printf("%d\n",ans);
    }
}

 

果然ST看着比线段树短多了....

 

 

每天刷题,身体棒棒!

POJ3264 (RMQのST解法)

原文:http://www.cnblogs.com/stxy-ferryman/p/7635817.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!