首页 > 其他 > 详细

1058. A+B in Hogwarts (20)

时间:2017-10-24 20:22:43      阅读:227      评论:0      收藏:0      [点我收藏+]

If you are a fan of Harry Potter, you would know the world of magic has its own currency system -- as Hagrid explained it to Harry, "Seventeen silver Sickles to a Galleon and twenty-nine Knuts to a Sickle, it‘s easy enough." Your job is to write a program to compute A+B where A and B are given in the standard form of "Galleon.Sickle.Knut" (Galleon is an integer in [0, 107], Sickle is an integer in [0, 17), and Knut is an integer in [0, 29)).

Input Specification:

Each input file contains one test case which occupies a line with A and B in the standard form, separated by one space.

Output Specification:

For each test case you should output the sum of A and B in one line, with the same format as the input.

Sample Input:

3.2.1 10.16.27

Sample Output:

14.1.28

#include<iostream>
#include<cstdio>
using namespace std;
int main(){
	int Galleon1,sickle1,knut1;
	int g_sum=0,s_sum=0,k_sum=0;
	scanf("%d.%d.%d %d.%d.%d",&Galleon1,&sickle1,&knut1,&g_sum,&s_sum,&k_sum);
	g_sum+=Galleon1;
	s_sum+=sickle1;
	k_sum+=knut1;
	int flag = k_sum/29;
	k_sum = k_sum%29;
	s_sum+=flag;
	flag=s_sum/17;
	s_sum=s_sum%17;
	g_sum+=flag;
	printf("%d.%d.%d\n",g_sum,s_sum,k_sum);
	return 0;
}

  

1058. A+B in Hogwarts (20)

原文:http://www.cnblogs.com/grglym/p/7725203.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!