Minimum Inversion Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21957 Accepted Submission(s):
13098
Problem Description
The inversion number of a given number sequence a1, a2,
..., an is the number of pairs (ai, aj) that satisfy i < j and ai >
aj.
For a given sequence of numbers a1, a2, ..., an, if we move the first
m >= 0 numbers to the end of the seqence, we will obtain another sequence.
There are totally n such sequences as the following:
a1, a2, ..., an-1,
an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m =
1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1
(where m = n-1)
You are asked to write a program to find the minimum
inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case
consists of two lines: the first line contains a positive integer n (n <=
5000); the next line contains a permutation of the n integers from 0 to
n-1.
Output
For each case, output the minimum inversion number on a
single line.
Sample Input
Sample Output
思路:线段树区间最值,单点增减,求最小逆序数,先求出一个,然后可以发现公式,进而推出其他的解
实现代码:
#include<bits/stdc++.h>
#include<cstdio>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int M = 5555;
int sum[M<<2];
int n;
void pushup(int rt){
sum[rt] = sum[rt<<1] + sum[rt<<1|1];
}
void build(int l,int r,int rt){
sum[rt] = 0;
if(l==r) return ;
int m = (l+r) >> 1;
build(lson);
build(rson);
}
void update(int p,int l,int r,int rt){
if(l == r){
sum[rt] ++;
return ;
}
int m = (l + r) >> 1;
if(p <= m) update(p,lson);
else update(p,rson);
pushup(rt);
}
int query(int L,int R,int l,int r,int rt){
if(L <= l && r <= R){
return sum[rt];
}
int m = (l + r) >> 1;
int ret = 0;
if(L <= m) ret += query(L,R,lson);
if(R>m) ret += query(L,R,rson);
return ret;
}
int a[M];
int main(){
int sum1;
while(scanf("%d",&n)!=EOF){
build(0,n-1,1);
int sum1 = 0;
for(int i = 0;i < n;i++){
scanf("%d",&a[i]);
sum1 += query(a[i]+1,n-1,0,n-1,1);
update(a[i]+1,0,n-1,1);
}
int ans = sum1;
for(int i = 0;i < n; i++){
sum1 = sum1 - a[i] + n - a[i] - 1;
ans = min(ans,sum1);
}
printf("%d\n",ans);
}
return 0;
}
HDU 1394 Minimum Inversion Number
原文:http://www.cnblogs.com/kls123/p/7840591.html