首页 > 其他 > 详细

TOJ 2711 Stars

时间:2014-02-09 16:11:46      阅读:320      评论:0      收藏:0      [点我收藏+]

描述

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

bubuko.com,布布扣

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it‘s formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.

输入

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

输出

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

样例输入

5
1 1
5 1
7 1
3 3
5 5

样例输出

1
2
1
1
0

提示

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

题目来源

Ural Collegiate 1999

 

做这题的时候一直超时。后来借了贞贞的代码看了,cjx更加混乱了,就两处地方改一改就不超时了。

实在搞不懂,求大神解答!

 

bubuko.com,布布扣
#include <stdio.h>
#include <string.h>
#define MAXN 32110

int n,m;
int L[15010];
int C[MAXN];
int lowbit(int t){
    return t&(t^(t-1));
}
int sum(int end){
    int sum(0);
    while(end>0){
        sum+=C[end];
        end-=lowbit(end);
    }
    return sum;
}

void add(int pos, int num){
    while(pos<=MAXN){
        C[pos]+=num;
        pos+=lowbit(pos); 
    }
}

int main(int argc, char *argv[])
{
    int x,y;
    scanf("%d",&n);
    for(int i=1; i<=n; i++){
        scanf("%d%d",&x,&y);
        x++;
        add(x,1);    
        L[sum(x)]++;            
        //----超时代码---
        int level=sum(x);
        L[level]++;
        add(x,1);        
        //---------------        
    }    
    for(int i=1; i<=n; i++)
        printf("%d\n",L[i]);                    
    //----超时代码---
    for(int i=0; i<n; i++)
        printf("%d\n",L[i]);        
    //---------------    
    return 0;
}
bubuko.com,布布扣

TOJ 2711 Stars

原文:http://www.cnblogs.com/chenjianxiang/p/3541147.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!