首页 > 其他 > 详细

1024. Palindromic Number (25)

时间:2017-12-01 23:01:32      阅读:281      评论:0      收藏:0      [点我收藏+]

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Non-palindromic numbers can be paired with palindromic ones via a series of operations. First, the non-palindromic number is reversed and the result is added to the original number. If the result is not a palindromic number, this is repeated until it gives a palindromic number. For example, if we start from 67, we can obtain a palindromic number in 2 steps: 67 + 76 = 143, and 143 + 341 = 484.

Given any positive integer N, you are supposed to find its paired palindromic number and the number of steps taken to find it.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and K, where N (<= 1010) is the initial numer and K (<= 100) is the maximum number of steps. The numbers are separated by a space.

Output Specification:

For each test case, output two numbers, one in each line. The first number is the paired palindromic number of N, and the second number is the number of steps taken to find the palindromic number. If the palindromic number is not found after K steps, just output the number obtained at the Kth step and K instead.

Sample Input 1:
67 3
Sample Output 1:
484
2
Sample Input 2:
69 3
Sample Output 2:
1353
3


代码:

#include <iostream>
#include <cstring>
#include <queue>
#include <string>
#include <cstdlib>
#include <algorithm>
using namespace std;
int main()
{
    char a[200],b[200];
    int c = 0,d,i;
    cin>>a>>d;
    int len = strlen(a);
    strcpy(b,a);
    reverse(a,a+len);
    for(i = 0;i < d;i ++)
    {
       if(strcmp(a,b) == 0)break;
       for(int j = 0;j < len;j ++)
       {
           c += a[j] - 0 + b[j] - 0;
           a[j] = c % 10 + 0;
           c /= 10;
       }
       if(c)
       {
           a[len ++] = 0 + c % 10;
           c /= 10;
           a[len] = \0;
       }
       strcpy(b,a);
       reverse(a,a+len);
    }
    cout<<a<<endl<<i;
}

 

1024. Palindromic Number (25)

原文:http://www.cnblogs.com/8023spz/p/7944557.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!