首页 > 其他 > 详细

hdu2374 A Game with Marbles(简单数学题)

时间:2014-07-05 10:44:09      阅读:355      评论:0      收藏:0      [点我收藏+]

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2374



Problem Description
There are n bowls, numbered from 1 to n. Initially, bowl i contains mi marbles. One game step consists of removing one marble from a bowl. When removing a marble from bowl i (i > 1), one marble is added to each of the first i-1 bowls; if a marble is removed from bowl 1, no new marble is added. The game is finished after each bowl is empty.

Your job is to determine how many game steps are needed to finish the game. You may assume that the supply of marbles is sufficient, and each bowl is large enough, so that each possible game step can be executed.

Input
The input contains several test cases. Each test case consists of one line containing one integer n (1 ≤ n ≤ 50), the number of bowls in the game. The following line contains n integers mi (1 ≤ i ≤ n, 0 ≤ mi ≤ 1000), where mi gives the number of marbles in bowl i at the beginning of the game.

The last test case is followed by a line containing 0.
 
Output
For each test case, print one line with the number of game steps needed to finish the game. You may assume that this number fits into a signed 64-bit integer.

Sample Input
10 3 3 3 3 3 3 3 3 3 3 5 1 2 3 4 5 0

Sample Output
3069 129
 
Source
 
Recommend
lcy   |   We have carefully selected several similar problems for you:  2371 2370 2369 2372 2375 

代码如下:
#include <cstdio>
int main()
{
	int n, i, j;
	__int64 a[56];
	while(scanf("%d",&n) && n)
	{
		for(i = 1; i <= n; i++)
		{
			scanf("%I64d",&a[i]);
		}
		__int64 ans = 0;
		for(i = n; i > 0; i--)
		{
			ans+=a[i];
			for(j = i-1; j > 0; j--)
			{
				a[j]+=a[i];
			}
		}
		printf("%I64d\n",ans);
	}
	return 0;
}



hdu2374 A Game with Marbles(简单数学题),布布扣,bubuko.com

hdu2374 A Game with Marbles(简单数学题)

原文:http://blog.csdn.net/u012860063/article/details/36696239

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!