首页 > 其他 > 详细

PAT 1005. Spell It Right

时间:2018-01-03 23:19:59      阅读:235      评论:0      收藏:0      [点我收藏+]

PAT 1005. Spell It Right (20)

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (<= 10100).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

代码如下

#include<iostream>
#include<vector>
using namespace std;
int main(){
    vector<string> map{"zero","one","two","three","four",
                       "five","six","seven","eight","nine"};
    string s;
    cin>>s;
    int sum=0;
    for(int i=0;i<s.size();i++)
    sum+=s[i]-'0';
    s=to_string(sum);
    for(int i=0;i<s.size();i++)
    i>0?cout<<" "<<map[s[i]-'0']:cout<<map[s[i]-'0'];
    return 0;
}

PAT 1005. Spell It Right

原文:https://www.cnblogs.com/A-Little-Nut/p/8186209.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!