首页 > 系统服务 > 详细

第七期 思科【cisco】命令

时间:2018-01-10 20:09:05      阅读:155      评论:0      收藏:0      [点我收藏+]

标签:per   广播   十进制   ble   range   路由   priority   helper   交换   

先给大家介绍一下思科的基础命令【运维必会】
root
Taren1 他人1

IP #.#.#.# 32位的二进制 子网掩码 网络位 主机位
A 1----126 255.0.0.0 网主主主 /8
B 128---191 255.255.0.0 网网主主 /16
C 192---223 255.255.255.0 网网网主 /24
D 224---239 组播
E 240---254 科研

八位的二进制数----------->十进制
00000000------------------0
11111111-----------------255
十进制 二进制

网段 ip范围 广播IP broadcast
1.0.0.0 1.0.0.1------1.255.255.254 1.255.255.255
2.0.0.0 2.0.0.1
126.0.0.0
128.0.0.0
128.1.0.0

127.0.0.1
私网IP
A 10.#.#.#--------10.#.#.#
B 172.16.#.#----------172.31.#.#
C 192.168.#.#------192.168.#.#

cmd
ipconfig
ping 目标ip

vlan 虚拟局域网 分组
Switch> 普通模式
Switch>enable
Switch# 全局模式
Switch#configure terminal
Switch(config)# 配置终端模式

Switch(config)#vlan 2 创建 vlan 2组
Switch(config-vlan)#exit 退出
Switch(config)#vlan 3 创建 vlan 3组
Switch(config-vlan)#exit 退出

Switch(config)#interface fastEthernet 0/3 进入 快速以太网接口 0/3
Switch(config-if)#switchport access vlan 2 交换机接口 接入 vlan 2组
Switch(config)#interface fastEthernet 0/4
Switch(config-if)#switchport access vlan 2

Switch(config)#interface fastEthernet 0/5
Switch(config-if)#switchport access vlan 3
Switch(config)#interface fastEthernet 0/6
Switch(config-if)#switchport access vlan 2

Switch#show vlan
Switch(config)#interface range fastEthernet 0/7-8 连续进入 快速以太网端口 0/7-8
Switch(config-if)#switchport access vlan 4

====================================================
trunk 开启 打标记功能
Switch(config)#interface fastEthernet 0/9
Switch(config-if)#switchport mode trunk 交换机端口 打标记功能

以太通道捆绑
Switch(config)#interface range fastEthernet 0/7-9
Switch(config-if-range)#switchport mode trunk
Switch(config-if-range)#channel-group 11 mode on 以太通道组11
加速带宽 备用线路

Router>
Router>enable
Router#configure terminal
Router(config)#interface fastEthernet 0/0
Router(config-if)#ip address 192.168.1.1 255.255.255.0
Router(config-if)#no shutdown

dhcp 地址池
Router>
Router>enable
Router#configure terminal
Router(config)#ip dhcp pool vlan1
Router(dhcp-config)#network 192.168.1.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.1.1
Router(dhcp-config)#dns-server 8.8.8.8

中继路由
Router/Swich(config)#interface fastEthernet 0/X(物理端口)
或Router/Swich(config)#interface vlan X(虚拟端口)
Router/Switch(config-if)#ip helper-address 10.10.0.1(DHCP服务器的IP地址)

静态路由
Router(config)#ip route 3.0.0.0 255.0.0.0 1.0.0.2 目标网段 子网掩码 下一跳
Router#show ip route

NAT 网络地址转换

network address translation
inside 里面
source 来源
static 静态

静态NAT网络地址转换
R1(config)#ip route 0.0.0.0 0.0.0.0 f0/1 默认路由
R1(config)#ip nat inside source static 192.168.4.33 1.0.0.100
R1(config)#ip nat inside source static 192.168.4.44 1.0.0.100
R1(config)#in f0/0
R1(config-if)#ip nat inside
R1(config)#in f0/1ff
R1(config-if)#ip nat outside

配置热备份路由协议(HSRP)
直连 ping通
tarena-R1(config)#interface f0/0
tarena-R1(config-if)#standby 1 ip 192.168.1.254
tarena-R1(config-if)#standby 1 priority 200 优先权
tarena-R1(config-if)#standby 1 preempt 占先权
tarena-R1(config-if)#standby 1 track f0/1 端口跟踪

tarena-R2(config)#interface f0/0
tarena-R2(config-if)#standby 1 ip 192.168.1.254 充当IP
tarena-R2(config-if)#standby 1 priority 195 优先权
tarena-R2(config-if)#standby 1 preempt 占先权
tarena-R2(config-if)#standby 1 track f0/1 端口跟踪

tarena-R1#show standby brief 查看
谢谢大家,思科的命令基本就这些,如有不足请留言
QQ:3297333814

第七期 思科【cisco】命令

标签:per   广播   十进制   ble   range   路由   priority   helper   交换   

原文:http://blog.51cto.com/13556999/2059539

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号