首页 > 其他 > 详细

思科拓扑---rip协议应用

时间:2018-01-14 17:36:11      阅读:25      评论:0      收藏:0      [点我收藏+]

标签:conf   ip网关   3.0   mar   fff   路由   ng-   udp   process   

一、RIP是什么?作用?
RIP:路由信息协议是内部网关协议IGP中最先得到使用的协议,他的作用是让路由器自主的交换路由信息表,但是只支持15跳,16跳被丢弃,它的套接字是UDP520。
RIP有两个版本v1和v2,v1是有类路由协议,v2是无类路由协议。

RIP v1 RIP v2
有类路由协议(宣告路由信息时不携带掩码) 无类路由协议(宣告路由信息时携带掩码)
广播更新(255.255.255.255) 组播更新(224.0.0.9)
不支持VLSM 支持VLSM
自动路由汇总,不可关闭 自动汇总可关闭,可手工汇总
不支持不连续子网 支持不连续子网

二、拓扑图展示
技术分享图片


三、所需设备以及相关设置
3台路由器、2台二层交换机、2台pc电脑、4条直通线和2条交叉线。
1.路由器配置

设备 接口 网关 所属网段
R1 g0/1 192.168.1.254 192.168.1.0/24
R1 g0/0 192.168.12.1 192.168.12.0/24
R2 g0/0 192.168.12.2 192.168.12.0/24
R2 g0/1 192.168.23.1 192.168.23.0/24
R3 g0/0 192.168.23.2 192.168.23.0/24
R3 g0/1 192.168.4.254 192.168.4.0/24

2.pc机设置

设备 ip地址 ip网关
pc0 192.168.1.1 192.168.1.254
pc1 192.168.4.1 192.168.4.254

四、配置思路以及代码展示
1.pc机配置思路:pc1设置ip地址和ip网关,pc2设置ip地址和ip网关
2.R1配置思路:设置接口g0/1和g0/0的网关,g0/1接口为192.168.1.254 子网掩码为255.255.255.0,g0/0接口为192.168.12.1 子网掩码为255.255.255.0。rip设置,设置版本为v2,关闭自动汇总,通告网段192.168.1.0和192.168.12.0。

Router>enable  //进入特权模式
Router#configure terminal  //全局配置模式

Router(config)#interface gigabitEthernet 0/1   //进入接口g0/1
Router(config-if)#no shutdown   //开启端口
Router(config-if)#ip address 192.168.1.254 255.255.255.0  //设置网关
Router(config-if)#exit  //退出

Router(config)#interface gigabitEthernet 0/0   //进入接口g0/0
Router(config-if)#no shutdown   //开启端口
Router(config-if)#ip address 192.168.12.1 255.255.255.0  //设置网关
Router(config-if)#exit  //退出

Router(config)#router rip  //开启rip,并进入
Router(config-router)#version 2  //设置模式为v2
Router(config-router)#no auto-summary  //关闭自动汇总,避免a类和b类地址无法识别vlsm,只能识别默认子网掩码。
Router(config-router)#network 192.168.1.0 //宣告网段192.168.1.0
Router(config-router)#network 192.168.12.0  //宣告网段192.168.12.0
Router(config-if)#exit  //退出

3.R2配置思路:设置接口g0/1和g0/0的网关,g0/1接口为192.168.23.1 子网掩码为255.255.255.0,g0/0接口为192.168.12.2 子网掩码为255.255.255.0。rip设置,设置版本为v2,关闭自动汇总,通告网段192.168.12.0和192.168.23.0。

Router>enable  //进入特权模式
Router#configure terminal  //全局配置模式

Router(config)#interface gigabitEthernet 0/1   //进入接口g0/1
Router(config-if)#no shutdown   //开启端口
Router(config-if)#ip address 192.168.23.1 255.255.255.0  //设置网关
Router(config-if)#exit  //退出

Router(config)#interface gigabitEthernet 0/0   //进入接口g0/0
Router(config-if)#no shutdown   //开启端口
Router(config-if)#ip address 192.168.23.1 255.255.255.0  //设置网关
Router(config-if)#exit  //退出

Router(config)#router rip  //开启rip,并进入
Router(config-router)#version 2  //设置模式为v2
Router(config-router)#no auto-summary  //关闭自动汇总,避免a类和b类地址无法识别vlsm,只能识别默认子网掩码。
Router(config-router)#network 192.168.12.0 //宣告网段192.168.12.0
Router(config-router)#network 192.168.23.0  //宣告网段192.168.23.0
Router(config-if)#exit  //退出

4.R3配置思路:设置接口g0/1和g0/0的网关,g0/1接口为192.168.4.254 子网掩码为255.255.255.0,g0/0接口为192.168.23.2 子网掩码为255.255.255.0。rip设置,设置版本为v2,关闭自动汇总,通告网段192.168.23.0和192.168.4.0。

Router>enable  //进入特权模式
Router#configure terminal  //全局配置模式

Router(config)#interface gigabitEthernet 0/1   //进入接口g0/1
Router(config-if)#no shutdown   //开启端口
Router(config-if)#ip address 192.168.4.254 255.255.255.0  //设置网关
Router(config-if)#exit  //退出

Router(config)#interface gigabitEthernet 0/0   //进入接口g0/0
Router(config-if)#no shutdown   //开启端口
Router(config-if)#ip address 192.168.23.2 255.255.255.0  //设置网关
Router(config-if)#exit  //退出

Router(config)#router rip  //开启rip,并进入
Router(config-router)#version 2  //设置模式为v2
Router(config-router)#no auto-summary  //关闭自动汇总,避免a类和b类地址无法识别vlsm,只能识别默认子网掩码。
Router(config-router)#network 192.168.4.0 //宣告网段192.168.4.0
Router(config-router)#network 192.168.23.0  //宣告网段192.168.23.0
Router(config-if)#exit  //退出

五、检测截图和检测命令截图
R1:Router#show running-config //查看所有配置
技术分享图片
技术分享图片
Router# show ip route rip //查看路由表中rip
技术分享图片


R2:Router#show running-config //查看所有配置
技术分享图片
Router# show ip route rip //查看路由表中rip
技术分享图片


R3:Router#show running-config //查看所有配置
技术分享图片
Router# show ip route rip //查看路由表中rip
技术分享图片


PC机ping通
技术分享图片

思科拓扑---rip协议应用

标签:conf   ip网关   3.0   mar   fff   路由   ng-   udp   process   

原文:http://blog.51cto.com/13445059/2060797

(0)
(0)
   
举报
评论 一句话评论(0
0条  
登录后才能评论!
© 2014 bubuko.com 版权所有 鲁ICP备09046678号-4
打开技术之扣,分享程序人生!
             

鲁公网安备 37021202000002号