首页 > 其他 > 详细

POJ 3176:Cow Bowling

时间:2014-07-08 17:59:50      阅读:447      评论:0      收藏:0      [点我收藏+]

Cow Bowling
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 13464   Accepted: 8897

Description

The cows don‘t use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this: 

          7



        3   8



      8   1   0



    2   7   4   4



  4   5   2   6   5
Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow‘s score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame. 

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.

Input

Line 1: A single integer, N 

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.

Output

Line 1: The largest sum achievable using the traversal rules

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample: 

          7

         *

        3   8

       *

      8   1   0

       *

    2   7   4   4

       *

  4   5   2   6   5
The highest score is achievable by traversing the cows as shown above.

简单的数塔DP问题。



#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>

using namespace std;

const int M = 350 +5;
int Cow[M][M];

int main()
{
    int n;
    while(scanf("%d", &n)!=EOF)
    {
        memset(Cow, 0, sizeof(Cow));
        for(int i=1; i<=n; i++)
            for(int j=1; j<=i; j++)
        {
            scanf("%d", &Cow[i][j]);
        }
        for(int i=n-1; i>=1; i--)
            for(int j=1; j<=i; j++)
            Cow[i][j]+=max(Cow[i+1][j], Cow[i+1][j+1]);
        cout<<Cow[1][1]<<endl;
    }

    return 0;
}


POJ 3176:Cow Bowling,布布扣,bubuko.com

POJ 3176:Cow Bowling

原文:http://blog.csdn.net/u013487051/article/details/37344035

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!