首页 > 其他 > 详细

POJ 1276 Cash Machine

时间:2014-07-10 21:01:06      阅读:329      评论:0      收藏:0      [点我收藏+]

Cash Machine
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 26675   Accepted: 9419

Description

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example, 

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10 

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each. 

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine. 

Notes: 
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc. 

Input

The program input is from standard input. Each data set in the input stands for a particular transaction and has the format: 

cash N n1 D1 n2 D2 ... nN DN 

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct. 

Output

For each set of data the program prints the result to the standard output on a separate line as shown in the examples below. 

Sample Input

735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10

Sample Output

735
630
0
0



多重背包。。。。。,第一次写。

打个模板过了。


AC代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
int dp[100005];
int g[15],z[15];
int v;

void ZOpack(int a)
{
    int i;
    for(i=v;i>=a;i--)
        dp[i]=max(dp[i],dp[i-a]+a);
}

void WQpack(int a)
{
    int i;
    for(i=a;i<=v;i++)
        dp[i]=max(dp[i],dp[i-a]+a);
}

void W(int gg,int zz)
{
    if(gg*zz>v)
        WQpack(zz);
    else{
        int k=1;
        while(k<gg)
        {
            ZOpack(k*zz);
            gg-=k;
            k<<=1;
        }
        ZOpack(gg*zz);
    }
}

int main()
{
    int n;
    int i,j;
    while(~scanf("%d%d",&v,&n))
    {
        memset(dp,0,sizeof dp);
        for(i=1;i<=n;i++)
            scanf("%d%d",&g[i],&z[i]);
        for(i=1;i<=n;i++)
            W(g[i],z[i]);
        printf("%d\n",dp[v]);
    }
    return 0;
}




POJ 1276 Cash Machine,布布扣,bubuko.com

POJ 1276 Cash Machine

原文:http://blog.csdn.net/hanhai768/article/details/37603615

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!