首页 > 其他 > 详细

1077. Kuchiguse (20)

时间:2018-03-13 16:22:03      阅读:231      评论:0      收藏:0      [点我收藏+]

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker‘s personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification:

Each input file contains one test case. For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character‘s spoken line. The spoken lines are case sensitive.

Output Specification:

For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai
#include<cstdio>
#include<cstring>
char s[100][260]; 
int minLen = 256;
int main(){
   int n,i,j;
   scanf("%d",&n);
   getchar();//记录换行符
   for(i = 0; i < n; i++){
        
     gets(s[i]);
     int len = strlen(s[i]);
     if(len < minLen) minLen = len;
     for(j = 0; j < len/2; j++){
         char temp = s[i][j];
         s[i][j] = s[i][len - j - 1];
         s[i][len - j - 1] = temp;
      } 
   }   
   int ans = 0;
   for(i = 0; i < minLen; i++){
        char c= s[0][i];
        bool same = true;
        for(j = 1; j < n; j++){
            if(c != s[j][i]){
                same = false;
                break;
            }
        }
        if(same) ans++;
        else break;
   }
   if(ans){
       for(i = ans -1; i >= 0; i--){
           printf("%c",s[0][i]);
       }
   }else{
       printf("nai");
   }
   
    return 0;
} 

 

1077. Kuchiguse (20)

原文:https://www.cnblogs.com/wanghao-boke/p/8557774.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!