Sum
Time Limit: 2000/1000MS (Java/Others) Memory Limit: 128000/64000KB (Java/Others)
SubmitStatus
Problem Description
You are given an N*N digit matrix and you can get several horizontal or vertical digit strings from any position.
For example:
123
456
789
In first row, you can get 6 digit strings totally, which are 1,2,3,12,23,123.
In first column, you can get 6 digit strings totally, which are 1,4,7,14,47,147.
We want to get all digit strings from each row and column, and write them on a paper. Now I wonder the sum of all number on the paper if we consider a digit string as a complete decimal number.
Input
The first line contains an integer N. (1 <= N <= 1000)
In the next N lines each line contains a string with N digit.
Output
Output the answer after module 1,000,000,007(1e9+7)。
Sample Input
3
123
456
789
Sample Output
2784
题目主要是导出公式:
如n行n列的每一行的和sum=1111.....111(n个1)*A1+111...111(n-1个1)*2*A2+.........+11*(n-1)*An-1+1*n*An;
求1111111...111我用到打表减少时间复杂。
AC代码如下:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#define M 1000000007
#define min(a,b) (a<b?a:b)
using namespace std;
char a[1005][1005];
long long b[1005];
int main()
{
int n;
long long i,j;
for(i=1;i<=1005;i++)
b[i]=0;
for(i=1;i<=1005;i++)
for(j=1;j<=i;j++)
{
b[i]=(b[i]*10+1)%M;
}
while(~scanf("%d",&n))
{
long long sum=0;
for(i=0;i<n;i++)
{
scanf("%s",&a[i]);
for(j=0;j<n;j++)
sum=(sum+((((j+1)*((long long)a[i][j]-'0'))*b[n-j])%M))%M;
}
for(j=0;j<n;j++)
{
for(i=0;i<n;i++)
sum=(sum+((((i+1)*((long long)a[i][j]-'0'))*b[n-i])%M))%M;
}
cout<<sum<<endl;
}
return 0;
}
ACdream原创群赛(16) J,布布扣,bubuko.com
ACdream原创群赛(16) J
原文:http://blog.csdn.net/hanhai768/article/details/37720591