首页 > 其他 > 详细

POJ 3041 Asteroids (匈牙利算法)

时间:2014-07-12 21:07:13      阅读:450      评论:0      收藏:0      [点我收藏+]

Asteroids

Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 14388
Accepted: 7828

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space.
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2


(匈牙利算法模板) 匈牙利算法是解决寻找二分图最大匹配的。
#include <iostream>
using namespace std;
#define N 510
int g[N][N],mark[N],link[N];
int n,x,y;
int dfs(int i)
{
    int j;
    for(j = 1;j<= y; j++)
    {
        if(g[i][j]&&!mark[j])            
        {
            
            mark[j] = 1;
            if(link[j]==-1||dfs(link[j]))
            {
                link[j] = i;               
                return 1;
            }
        }
    }
    return 0;                         
}   //完全是匈牙利算法模板。

int main()
{
    int i,sum = 0;
    int a,b;
    while(scanf("%d%d",&x,&n)!=EOF)
    {  y=x;
       memset(g,0,sizeof(g));
       sum=0;
       for(i=1;i<= n;i++)
       {
           scanf("%d%d",&a,&b);
           g[a][b]=1;
       }
       memset(link,-1,sizeof(link));   
       for(i = 1; i<=x; i++)
       {  
           memset(mark,0,sizeof(mark));  //最为重要的就是每次mark清零。
                                         //这么做是为了只保留link中对应匹配。
           if(dfs(i))   
               sum+=1;                   //找到增广路。
           
       }   
       printf("%d\n",sum);
    } 
    return 0;
} 
还是伟大的模板,搞了半天还不确定是不是明白了。

POJ 3041 Asteroids (匈牙利算法),布布扣,bubuko.com

POJ 3041 Asteroids (匈牙利算法)

原文:http://blog.csdn.net/qq2256420822/article/details/37659231

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!