首页 > 其他 > 详细

1085. Perfect Sequence (25)

时间:2018-03-29 13:13:53      阅读:214      评论:0      收藏:0      [点我收藏+]

Given a sequence of positive integers and another positive integer p. The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter. In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8
#include<cstdio>                                    
#include<algorithm>                                 
using namespace std;                                
int n,p,a[100010];                                  
                                                    
int binarySearch(int i, long long x){               
    if(a[n - 1] <= x) return n;                        
    int l = i + 1, r = n - 1;                          
    while(l < r){                                      
        int mid = (r + l) / 2;                            
        if(a[mid] <= x){                                  
            l = mid + 1;                                     
        }else{                                            
            r = mid;                                         
        }                                                 
    }                                                  
    return l;                                          
}                                                   
                                                    
int main(){                                         
                                                       
    scanf("%d%d",&n,&p);                               
    for(int i = 0; i < n; i++){                        
        scanf("%d",&a[i]);                                
    }                                                  
    sort(a,a+n);                                       
    int ans = 1;                                       
    for(int i = 0; i < n; i++){                        
                                                          
        int j = binarySearch(i,(long long)a[i]*p);        
        ans = max(ans, j - i);                            
    }                                                  
    printf("%d\n",ans);                                
    return 0;                                          
}                                                   

 

1085. Perfect Sequence (25)

原文:https://www.cnblogs.com/wanghao-boke/p/8669088.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!