Equations
Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5226 Accepted Submission(s): 2079
Problem Description
Consider equations having the following form:
a*x1^2+b*x2^2+c*x3^2+d*x4^2=0
a, b, c, d are integers from the interval [-50,50] and any of them cannot be 0.
It is consider a solution a system ( x1,x2,x3,x4 ) that verifies the equation, xi is an integer from [-100,100] and xi != 0, any i ∈{1,2,3,4}.
Determine how many solutions satisfy the given equation.
Input
The input consists of several test cases. Each test case consists of a single line containing the 4 coefficients a, b, c, d, separated by one or more blanks.
End of file.
Output
For each test case, output a single line containing the number of the solutions.
Sample Input
Sample Output
哈希表基础题:
#include<stdio.h>
#include<algorithm>
#define M 2000004
int hash[M];
int main ()
{
int a,b,c,d;
int i,j;
int sum,s[101];
for(i=1;i<=100;i++)
s[i]=i*i;
while(~scanf("%d%d%d%d",&a,&b,&c,&d))
{
if((a>0&&b>0&&c>0&&d>0)||(a<0&&b<0&&c<0&&d<0))
{
printf("0\n");
continue;
}
sum=0;
memset(hash,0,sizeof(hash));
for(i=1;i<=100;i++)
for(j=1;j<=100;j++)
hash[a*s[i]+b*s[j]+M/2]++; // M/2 是防止下标为负数。
for(i=1;i<=100;i++)
for(j=1;j<=100;j++)
sum+=hash[-(c*s[i]+d*s[j])+M/2]; // 亏大神们想得出啊!
printf("%d\n",sum*16);
}
return 0;
}
hdu 1469 Equations,布布扣,bubuko.com
hdu 1469 Equations
原文:http://blog.csdn.net/fyxz1314/article/details/37819765