首页 > 其他 > 详细

POJ1273_Drainage Ditches(网络流)

时间:2014-07-16 17:21:56      阅读:287      评论:0      收藏:0      [点我收藏+]
Drainage Ditches
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 54887   Accepted: 20919

Description

Every time it rains on Farmer John‘s fields, a pond forms over Bessie‘s favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie‘s clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50

Source

解题报告
听说第一发网络流要纪念一下,有模板的嫌疑,Discuss的情况都遇上了,多组忘了清零,重边忘了处理。
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <queue>
#define inf 99999999
#define M 200+10
using namespace std;
struct edge
{
    int c,f;
}edge[M][M];
int n,m,vis[M],a[M],pre[M],f;
queue<int>Q;
void ford()
{
    while(1)
    {
        memset(pre,-1,sizeof(pre));
        memset(a,-1,sizeof(a));
        memset(vis,-1,sizeof(vis));
        while(!Q.empty())
        Q.pop();
        Q.push(1);
        pre[1]=1;
        vis[1]=0;
        a[1]=inf;
        while(!Q.empty()&&vis[m]==-1)
        {
            int u=Q.front();
            Q.pop();
            for(int v=1;v<=m;v++)
            {
                if(vis[v]==-1)
                {
                    if(edge[u][v].f<edge[u][v].c)
                    {
                        a[v]=min(a[u],edge[u][v].c-edge[u][v].f);
                        vis[v]=0;
                        pre[v]=u;
                        Q.push(v);
                    }
                    else if(edge[v][u].f>0)
                    {
                        a[v]=min(a[u],edge[v][u].f);
                        vis[v]=0;
                        pre[v]=-u;
                        Q.push(v);
                    }
                }
            }
            vis[u]=1;
        }
        if(vis[m]==-1||a[m]==0)
        break;
        int k1=m,k2=abs(pre[k1]);
        int aaa=a[m];
        while(1)
        {
            edge[k2][k1].f+=aaa;
            edge[k1][k2].f-=aaa;
            if(k2==1)break;
            k1=k2;k2=abs(pre[k2]);
        }
        f+=a[m];
    }
}
int main()
{
    int i,j,u,v,w;
    while(~scanf("%d%d",&n,&m))
    {
        f=0;
        memset(edge,0,sizeof(edge));
        for(i=0;i<n;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            edge[u][v].c+=w;
        }
        ford();
        printf("%d\n",f);
    }
    return 0;
}


POJ1273_Drainage Ditches(网络流),布布扣,bubuko.com

POJ1273_Drainage Ditches(网络流)

原文:http://blog.csdn.net/juncoder/article/details/37812897

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!