首页 > 其他 > 详细

B_Dp

时间:2014-07-18 22:21:52      阅读:340      评论:0      收藏:0      [点我收藏+]
<span style="color:#000099;">/*
B - 简单dp 例题
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u
Submit

Status
Description
7
3   8
8   1   0
2   7   4   4
4   5   2   6   5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
Input
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
Output
Your program is to write to standard output. The highest sum is written as an integer.
Sample Input
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
Sample Output
30
By Grant Yuan
2014.7.16*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
int a[101][101];
int f[101][101];
int n;
int l,r;
int max(int a1,int a2)
{
    if(a1>=a2)
      return a1;
    return a2;
}
int main()
{
    while(~scanf("%d",&n)){
          memset(a,0,sizeof(a));
      memset(f,0,sizeof(f));
      for(int i=1;i<=n;i++)
        for(int j=1;j<=i;j++)
         scanf("%d",&a[i][j]);
      for(int i=1;i<=n;i++)
        for(int j=1;j<=i;j++)
          {
             f[i][j]=max(f[i-1][j],f[i-1][j-1])+a[i][j];
          }
          int m=0;
      for(int i=1;i<=n;i++)
        {
            if(f[n][i]>m)
              m=f[n][i];
        }
        cout<<m<<endl;

      }
}
</span>

B_Dp,布布扣,bubuko.com

B_Dp

原文:http://blog.csdn.net/yuanchang_best/article/details/37879193

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!