首页 > 其他 > 详细

Fibonacci Again

时间:2014-02-11 00:24:16      阅读:488      评论:0      收藏:0      [点我收藏+]

Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

 

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

 

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

 

Sample Input

0

1

2

3

4

5

 

Sample Output

no

no

yes

no

no

no

 

#include<stdio.h>

int a[1000001];

int main()

{



     a[0]=1;

     a[1]=2;

     long int q,w;

     for(w=2;w<1000000;w++)

     {

         a[w]=a[w-1]+a[w-2];

         if(a[w]%3==0)

             a[w]=0;

         else

             a[w]=a[w]%3;

     }

     while(scanf("%ld",&q)!=EOF)

     {

         if(a[q]%3==0)

             printf("yes\n");

         else

             printf("no\n");

     }

     return 0;

}

Fibonacci Again

原文:http://www.cnblogs.com/jiangweibo/p/3543444.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!