首页 > 其他 > 详细

PAT 1006

时间:2014-02-11 01:54:16      阅读:311      评论:0      收藏:0      [点我收藏+]

1006. Sign In and Sign Out (25)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in‘s and out‘s, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time 

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3 
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133 

简单题,找到最大最小即可。

 

代码

bubuko.com,布布扣
 1 #include <stdio.h>
 2 
 3 int main()
 4 {
 5     int M;
 6     char ID[1000][16];
 7     int sign_in_time[1000];
 8     int sign_out_time[1000];
 9     int in_h,in_min,in_sec,out_h,out_min,out_sec;
10     while(scanf("%d",&M) != EOF){
11         int i;
12         for(i=0;i<M;++i){
13             scanf("%s%d:%d:%d %d:%d:%d",ID[i],&in_h,&in_min,&in_sec,&out_h,&out_min,&out_sec);
14             sign_in_time[i] = in_h * 3600 + in_min * 60 + in_sec;
15             sign_out_time[i] = out_h * 3600 + out_min * 60 + out_sec;
16         }
17         int in_min = sign_in_time[0],in_ind = 0;
18         int out_max = sign_out_time[0],out_ind = 0;
19         for(i=1;i<M;++i){
20             if(sign_in_time[i] < in_min){
21                 in_min = sign_in_time[i];
22                 in_ind = i;
23             }
24             if(sign_out_time[i] > out_max){
25                 out_max = sign_out_time[i];
26                 out_ind = i;
27             }
28         }
29         printf("%s %s\n",ID[in_ind],ID[out_ind]);
30     }
31     return 0;
32 }
bubuko.com,布布扣

PAT 1006

原文:http://www.cnblogs.com/boostable/p/pat_1006.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!