首页 > 其他 > 详细

POJ 1159 Palindrome DP

时间:2014-07-18 12:21:33      阅读:362      评论:0      收藏:0      [点我收藏+]
Palindrome
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 51913   Accepted: 17877

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2



#include<iostream>
#include<cstring>
using namespace std;

int v[2][5005];
char c1[5010],c2[5010];

int max(int x,int y)
{
	return x>y?x:y;
}

int main()
{
	int n;
	while(cin>>n)
	{ 
		int i;
		for(i=1;i<=n;i++)
		{
			cin>>c1[i];
			c2[n-i+1]=c1[i];
		}

		memset(v,0,sizeof(v));
		int j;
		int m=0;
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=n;j++)
			{
				if(c1[i]==c2[j])
					v[i%2][j]=v[(i-1)%2][j-1]+1;
				else
					v[i%2][j]=max(v[(i-1)%2][j],v[i%2][j-1]);
				if(m<v[i%2][j])
					m=v[i%2][j];
			}
			
		}

		cout<<n-m<<endl;
	}

	return 0;
}


POJ 1159 Palindrome DP,布布扣,bubuko.com

POJ 1159 Palindrome DP

原文:http://blog.csdn.net/hyccfy/article/details/37914275

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!