首页 > 其他 > 详细

poj 2406 Power Strings KMP

时间:2014-07-19 23:47:19      阅读:460      评论:0      收藏:0      [点我收藏+]

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

代码:
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char  s[1000005];              //题目没说 结果开小了就runtime error。。
int next[1000005];
int s1,ss;
void getnext(char *s)
{
	int i=0;
	int j=-1;
	next[0]=-1;
	while(i<s1)
	{
		if(j==-1||s[i]==s[j])
		{
			++i;
			++j;
			next[i]=j;
		}
		else
			j=next[j];
	}	
	i=s1-j;                
	if(s1%i==0)
		ss=s1/i;
	else 
		ss=1;
	return ;		
}
int main()
{
	while(scanf("%s",s))
	{
		if(s[0]=='.')
			break;
		s1=strlen(s);
		getnext(s);
		cout<<ss<<endl;
	}		
	return 0;
}

 

poj 2406 Power Strings KMP

原文:http://blog.csdn.net/axuan_k/article/details/37965983

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!