首页 > 其他 > 详细

Ice_cream’s world III//最小生成树kruskal

时间:2018-06-24 00:03:55      阅读:234      评论:0      收藏:0      [点我收藏+]

题目:

 

Ice_cream’s world III

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2566    Accepted Submission(s): 904

Problem Description
ice_cream’s world becomes stronger and stronger; every road is built as undirected. The queen enjoys traveling around her world; the queen’s requirement is like II problem, beautifies the roads, by which there are some ways from every city to the capital. The project’s cost should be as less as better.
 
Input
Every case have two integers N and M (N<=1000, M<=10000) meaning N cities and M roads, the cities numbered 0…N-1, following N lines, each line contain three integers S, T and C, meaning S connected with T have a road will cost C.
 
Output
If Wiskey can’t satisfy the queen’s requirement, you must be output “impossible”, otherwise, print the minimum cost in this project. After every case print one blank.
 
Sample Input
2 1
0 1 10
 
4 0
 
Sample Output
10
impossible
 
思路:
 
代码:
#include <iostream>
#include <vector>
#include <algorithm>

using namespace std;
const int size = 1e4 + 1;
struct edge
{
    int a, b, c;
};
struct edge edges[size];
int un[size];

int cmp(edge x, edge y)
{
    return x.c < y.c;
}

int find(int x)
{
    if(x == un[x])
        return x;
    return find(un[x]);
}

void Union(int x, int y)
{
    int c1 = find(x);
    int c2 = find(y);
    un[c1] = c2;
}

int main()
{
    int N, M;
    int S, T, C;
    while(cin >> N >> M)
    {
        for(int i = 0; i < N; i++)
            un[i] = i;

        for(int i = 0; i < M; i++)
        {
            cin >> edges[i].a >> edges[i].b >> edges[i].c;
        }
        sort(edges, edges+M, cmp);
        int count = N;
        int ans = 0;
        for(int i = 0; i < M; i++)
        {
            if(find(edges[i].a) == find(edges[i].b))
                continue;
            Union(edges[i].a, edges[i].b);
            count--;
            ans+=edges[i].c;
        }
        if(count != 1)
        {
            printf("impossible\n\n");
            continue;
        }
        printf("%d\n\n", ans);
    }
    return 0;
}

 

Ice_cream’s world III//最小生成树kruskal

原文:https://www.cnblogs.com/w-j-c/p/9218954.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!