首页 > 其他 > 详细

HDU 2844 Coins

时间:2014-07-20 23:01:13      阅读:520      评论:0      收藏:0      [点我收藏+]
Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
8 4
 

Source
 
裸的多重背包SO:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn=1000005;
const int INF=0x3f3f3f3f;
int a[110],c[110];
int dp[maxn];
int n,m;

void solve()
{
    for(int i=0;i<n;i++)
    {
        if(a[i]*c[i]>=m)
        {
            for(int j=a[i];j<=m;j++)
                dp[j]=max(dp[j],dp[j-a[i]]+a[i]);
        }
        else
        {
            for(int k=1;k<=c[i];k*=2)
            {
                for(int j=m;j>=k*a[i];j--)
                {
                    dp[j]=max(dp[j],dp[j-k*a[i]]+k*a[i]);
                }
                c[i]-=k;
            }
            if(c[i]>0)
            {
                for(int j=m;j>=c[i]*a[i];j--)
                    dp[j]=max(dp[j],dp[j-c[i]*a[i]]+c[i]*a[i]);
            }
        }
    }
    int cnt=0;
    for(int i=1;i<=m;i++)
    {
        if(dp[i]>0)
            cnt++;
    }
    printf("%d\n",cnt);
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            scanf("%d",&c[i]);
        for(int i=0;i<maxn;i++)
            dp[i]=-INF;
        dp[0]=1;
        solve();
    }
    return 0;
}

HDU 2844 Coins,布布扣,bubuko.com

HDU 2844 Coins

原文:http://blog.csdn.net/u013582254/article/details/37995501

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!