首页 > 其他 > 详细

HDU 2005 第几天?

时间:2018-07-17 00:29:27      阅读:214      评论:0      收藏:0      [点我收藏+]

http://acm.hdu.edu.cn/showproblem.php?pid=2005

 

Problem Description
给定一个日期,输出这个日期是该年的第几天。
 
Input
输入数据有多组,每组占一行,数据格式为YYYY/MM/DD组成,具体参见sample input ,另外,可以向你确保所有的输入数据是合法的。
 
Output
对于每组输入数据,输出一行,表示该日期是该年的第几天。
 
Sample Input
1985/1/20
2006/3/12
 
Sample Output
20
71
 
代码:
#include <bits/stdc++.h>

using namespace std;

int rn[15]= {0,31,29,31,30,31,30,31,31,30,31,30,31};
int pn[15]= {0,31,28,31,30,31,30,31,31,30,31,30,31};

int main()
{
    int year,mon,day;

    while(~scanf("%d/%d/%d",&year,&mon,&day))
    {
        int sum=0,res=0;
        if((year%4==0&&year%100!=0)||year%400==0)
        {
            //cout<<"yes"<<endl;
            for(int i=1; i<=mon; i++)
            {
                sum+=rn[i-1];
            }
        }
        else
        {
            //cout<<"no"<<endl;
            for(int i=1; i<=mon; i++)
            {
                sum+=pn[i-1];
            }

        }
        res=sum+day;
        //cout<<rn[1]<<endl;
        printf("%d\n",res);
    }
    return 0;
}

  

 

HDU 2005 第几天?

原文:https://www.cnblogs.com/zlrrrr/p/9321151.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!