首页 > 其他 > 详细

FatMouse' Trade

时间:2018-07-17 00:39:05      阅读:257      评论:0      收藏:0      [点我收藏+]

FatMouse‘ Trade

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 92544    Accepted Submission(s): 32114


Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
 

 

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1‘s. All integers are not greater than 1000.
 

 

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
 

 

Sample Input
5 3 7 2 4 3 5 2 20 3 25 18 24 15 15 10 -1 -1
 

 

Sample Output
13.333 31.500
 
 
解题思路:贪心,开一个结构体后按照平均值从大到小排序,先换掉平均值大的房间里的JavaBean,输出用printf输出,用setpricision会wa,原因在于setprecision会四舍五入丢失精度。
#include<bits/stdc++.h>
#include<stdio.h>
using namespace std;

struct jb
{
    double j,f,avg;
};

bool cmp(jb x,jb y)
{
    return x.avg<y.avg;
}

int main()
{
    double n;
    int m;
    while(cin>>n>>m&&n!=-1)
    {
        jb s[1001];
        for(int i=0;i<m;i++){cin>>s[i].j>>s[i].f;s[i].avg=s[i].j/s[i].f;}
        sort(s,s+m,cmp);
        double sum=0;
        for(int i=m-1;i>=0;--i)
        {
            if(n>=s[i].f)
            {
                n-=s[i].f;
                sum+=s[i].j;
            }
            else if(n<s[i].f&&n>0)
            {
                sum+=s[i].avg*n;
                break;
            }
        }
        printf("%.3lf\n",sum);
        //cout<<fixed<<setprecision(3)<<sum<<endl;
    }
    return 0;
}

 

FatMouse' Trade

原文:https://www.cnblogs.com/wjw2018/p/9321184.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!