首页 > 其他 > 详细

HDU 2178 猜数字

时间:2018-08-04 10:32:15      阅读:112      评论:0      收藏:0      [点我收藏+]

http://acm.hdu.edu.cn/showproblem.php?pid=2178

 

Problem Description
A有1数m,B来猜.B每猜一次,A就说"太大","太小"或"对了" 。 
问B猜n次可以猜到的最大数。 
 
Input
第1行是整数T,表示有T组数据,下面有T行 
每行一个整数n (1 ≤ n ≤ 30) 
 
Output
猜n次可以猜到的最大数
 
Sample Input
2
1
3
 
Sample Output
1
7
 
代码:
#include <bits/stdc++.h>
using namespace std;

int main() {
    int T;
    scanf("%d", &T);
    while(T --) {
        int x;
        scanf("%d", &x);
        int num = pow(2, x) - 1;
        printf("%d\n", num);
    }
    return 0;
}

  

HDU 2178 猜数字

原文:https://www.cnblogs.com/zlrrrr/p/9417369.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!