首页 > 其他 > 详细

Spreading the Wealth

时间:2014-07-24 12:23:45      阅读:274      评论:0      收藏:0      [点我收藏+]
Time Limit: 6000MS   Memory Limit: Unknown   64bit IO Format: %lld & %llu

[]   [Go Back]   [Status]  

Description

bubuko.com,布布扣


 F. Spreading the Wealth 

Problem

A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.

The Input

There is a number of inputs. Each input begins with n(n<1000001), the number of people in the village. n lines follow, giving the number of coins of each person in the village, in counterclockwise order around the table. The total number of coins will fit inside an unsigned 64 bit integer.

The Output

For each input, output the minimum number of coins that must be transferred on a single line.

Sample Input

3
100
100
100
4
1
2
5
4

Sample Output

0
4
#include<iostream>
#include<cstdio>
#include<algorithm>
using namespace std;
long long a[1000010],b[1000010],tot,m,x1,ans;
int main()
{
	int i,n;
	while(scanf("%d",&n)==1)
	{
		tot=0;
		for(i=0;i<n;i++)
		{	scanf("%d",&a[i]);tot+=a[i];}
		m=tot/n;
		b[0]=0;
		for(i=0;i<n;i++)
			b[i]=b[i-1]+a[i]-m;
		sort(b,b+n);
		x1=0;
            x1=b[n/2];
			ans=0;
			for(i=0;i<n;i++)
				ans+=abs(x1-b[i]);
			printf("%lld\n",ans);
	}

	return 0;
}


Spreading the Wealth,布布扣,bubuko.com

Spreading the Wealth

原文:http://blog.csdn.net/rememberautumn/article/details/38082543

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!