Time Limit: 1000MS | Memory Limit: 10000K | |||
Total Submissions: 41845 | Accepted: 17564 | Special Judge |
Description
Input
Output
Sample Input
2 6 19 0
Sample Output
10 100100100100100100 111111111111111111
Source
#include<iostream>
using namespace std;
typedef long long ll;
typedef unsigned long long ull;
typedef pair<int,int> PII;
const ll mod=998244353;
#define pb push_back
#define mp make_pair
#define all(x) (x).begin(),(x).end()
#define fi first
#define se second
//head
#define MAX 1000
int n;
int flag;
void dfs(int cur,ll sum)
{
if(cur==19)return ;
if(flag) return ;
if(sum%n==0&&sum!=0)
{
flag=1;
cout<<sum<<endl;
return ;
}
else
dfs(cur+1,sum*10),dfs(cur+1,sum*10+1);
}
int main()
{
cin.tie(0);
cout.tie(0);
ios::sync_with_stdio(0);
while(cin>>n)
{
if(n==0)break;
flag=0;
dfs(0,1);
}
return 0;
}
poj1426 Find The Multiple (DFS)
原文:https://www.cnblogs.com/zhgyki/p/9503250.html