首页 > 其他 > 详细

[ACM] POJ 1286 Necklace of Beads (Polya计数,直接套公式)

时间:2014-07-25 11:04:01      阅读:528      评论:0      收藏:0      [点我收藏+]

Necklace of Beads
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 6547   Accepted: 2734

Description

Beads of red, blue or green colors are connected together into a circular necklace of n beads ( n < 24 ). If the repetitions that are produced by rotation around the center of the circular necklace or reflection to the axis of symmetry are all neglected, how many different forms of the necklace are there? 
bubuko.com,布布扣

Input

The input has several lines, and each line contains the input data n. 
-1 denotes the end of the input file. 

Output

The output should contain the output data: Number of different forms, in each line correspondent to the input data.

Sample Input

4
5
-1

Sample Output

21
39

Source


解题思路:

和http://blog.csdn.net/sr_19930829/article/details/38108871几乎是一模一样的。考虑n=0的情况,要不然runtime error- - ! 

代码:

#include <iostream>
#define LL long long
using namespace std;

int gcd(int a,int b)
{
    return b==0?a:gcd(b,a%b);
}

LL power(LL p,LL n)
{
    LL sum=1;
    while(n)
    {
        if(n&1)
            sum*=p;
        p*=p;
        n/=2;

    }
    return sum;
}

int main()
{
    int n;
    while(cin>>n&&n!=-1)
    {
        if(n==0)//考虑n等于0的情况。。
        {
            cout<<0<<endl;
            continue;
        }
        LL ans=0;
        for(int i=1;i<=n;i++)
            ans+=power(3,gcd(i,n));
        if(n&1)
            ans+=n*power(3,n/2+1);
        else
            ans+=(power(3,n/2+1)+power(3,n/2))*(n/2);
        ans/=n*2;
        cout<<ans<<endl;
    }
    return 0;
}


[ACM] POJ 1286 Necklace of Beads (Polya计数,直接套公式),布布扣,bubuko.com

[ACM] POJ 1286 Necklace of Beads (Polya计数,直接套公式)

原文:http://blog.csdn.net/sr_19930829/article/details/38109823

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!