首页 > 其他 > 详细

HDU 2070 Fibbonacci Number

时间:2014-07-25 11:05:31      阅读:275      评论:0      收藏:0      [点我收藏+]

Fibbonacci Number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 13400    Accepted Submission(s): 6677


Problem Description
Your objective for this question is to develop a program which will generate a fibbonacci number. The fibbonacci function is defined as such:

f(0) = 0
f(1) = 1
f(n) = f(n-1) + f(n-2)

Your program should be able to handle values of n in the range 0 to 50.
 

Input
Each test case consists of one integer n in a single line where 0≤n≤50. The input is terminated by -1.
 

Output
Print out the answer in a single line for each test case.
 

Sample Input
3 4 5 -1
 

Sample Output
2 3 5
Hint
Note:
you can use 64bit integer: __int64
 



#include<stdio.h>
__int64 a[55]={0,1};
int main()
{
	int i;
	int m;
	for(i=2;i<51;i++)
	a[i]=a[i-1]+a[i-2];
	while(scanf("%d",&m)&&(m!=-1))
	{
		printf("%I64d\n",a[m]);
	}
	return 0;
}
	





HDU 2070 Fibbonacci Number,布布扣,bubuko.com

HDU 2070 Fibbonacci Number

原文:http://blog.csdn.net/qq_16767427/article/details/38109557

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!