首页 > 其他 > 详细

HDU 4861 Couple doubi(找规律|费马定理)

时间:2014-07-26 01:25:06      阅读:344      评论:0      收藏:0      [点我收藏+]
Couple doubi
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
 

Input

Multiply Test Cases. 
In the first line there are two Integers k and p(1<k,p<2^31). 
 

Output

For each line, output an integer, as described above.
 

Sample Input

2 3 20 3
 

Sample Output

YES NO
//打表找规律的代码
#include<stdio.h>
#include<math.h>
#include<string.h>
int main(void)
{
    int i,j,k,p;
    int value[100];
    while(scanf("%d%d",&k,&p)!=EOF)
    {
        memset(value,0,sizeof(value));
        for(int i=1;i<=k;i++)
        {
            for(int j=1;j<p;j++){
                value[i]=(int)(value[i]+pow(j,i))%p;
            }
            printf("%d ",value[i]);
        }
        printf("\n");
    }
    return 0;
}
/*
打表找了下规律,发现2的时候所有球都是1,
3的时候是0 2 0 2 0 2 0 2···交替,
5的时候是0 0 0 4 0 0 0 4 0 0 0 4···, 
7 的时候是0 0 0 0 0 6 0 0 0 0 0 6·····,这样规律就出来了。
*/
//ac
#include<stdio.h>
int main()
{
    int k, p;
    while(~scanf("%d%d", &k, &p))
    {
        if((k/(p-1))%2==1)
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}
//费马定理神马看这里吧!
http://blog.csdn.net/u011439796/article/details/38048963

 

HDU 4861 Couple doubi(找规律|费马定理),布布扣,bubuko.com

HDU 4861 Couple doubi(找规律|费马定理)

原文:http://www.cnblogs.com/woshijishu3/p/3868864.html

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!