首页 > 其他 > 详细

HDU1028 Ignatius and the Princess III 【母函数模板题】

时间:2014-07-26 02:21:36      阅读:231      评论:0      收藏:0      [点我收藏+]

Ignatius and the Princess III

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12521    Accepted Submission(s): 8838


Problem Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.

"The second problem is, given an positive integer N, we define an equation like this:
  N=a[1]+a[2]+a[3]+...+a[m];
  a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
  4 = 4;
  4 = 3 + 1;
  4 = 2 + 2;
  4 = 2 + 1 + 1;
  4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
 

Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
 

Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
 

Sample Input
4 10 20
 

Sample Output
5 42 627

整数拆分无限取,跟着包子做的题,就当做模板来用吧。

#include <stdio.h>
#define maxn 122

int c1[maxn], c2[maxn];

int main()
{
    int n, i, j, k;
    while(scanf("%d", &n) != EOF){
        for(i = 0; i <= n; ++i){
            c1[i] = 1; c2[i] = 0;
        }
        for(i = 2; i <= n; ++i){
            for(j = 0; j <= n; ++j)
                for(k = j; k <= n; k += i)
                    c2[k] += c1[j];        
            for(k = 0; k <= n; ++k){
                c1[k] = c2[k]; c2[k] = 0;
            }
        }
        printf("%d\n", c1[n]);
    }
    return 0;
}


HDU1028 Ignatius and the Princess III 【母函数模板题】,布布扣,bubuko.com

HDU1028 Ignatius and the Princess III 【母函数模板题】

原文:http://blog.csdn.net/chang_mu/article/details/38123083

(0)
(0)
   
举报
评论 一句话评论(0
关于我们 - 联系我们 - 留言反馈 - 联系我们:wmxa8@hotmail.com
© 2014 bubuko.com 版权所有
打开技术之扣,分享程序人生!